import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:06|\\+36|0036)\\d{1,2}\\d{3}\\d{3,4}$";
final String string = "+36301404975\n"
+ "06301404975\n"
+ "0036301404975\n"
+ "1234567890\n"
+ "0123456789\n"
+ "00123456789\n"
+ "+12345678901";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}