using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:06|\+36|0036)\d{1,2}\d{3}\d{3,4}$";
string input = @"+36301404975
06301404975
0036301404975
1234567890
0123456789
00123456789
+12345678901";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}