package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:06|\+36|0036)\d{1,2}\d{3}\d{3,4}$`)
var str = `+36301404975
06301404975
0036301404975
1234567890
0123456789
00123456789
+12345678901`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}