$re = '/^(?:06|\+36|0036)\d{1,2}\d{3}\d{3,4}$/m';
$str = '+36301404975
06301404975
0036301404975
1234567890
0123456789
00123456789
+12345678901';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);