use strict;
my $str = '+36301404975
06301404975
0036301404975
1234567890
0123456789
00123456789
+12345678901';
my $regex = qr/^(?:06|\+36|0036)\d{1,2}\d{3}\d{3,4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}