const regex = /^(?:06|\+36|0036)\d{1,2}\d{3}\d{3,4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:06|\\+36|0036)\\d{1,2}\\d{3}\\d{3,4}$', 'gm')
const str = `+36301404975
06301404975
0036301404975
1234567890
0123456789
00123456789
+12345678901`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}