import Foundation
let pattern = #"^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
import { contextBuilder } from '@graphql/context';
import resolvers from '@graphql/resolvers';
import {
getDeviceFromHeaders,
getUserFromHeaders,
getRealIp,
} from '@utils/headers';
export * from './ChallengesAPI';
export * from './HealthDataCollectorAPI';
export * from './AlfredAPI';
import { formatRoundedNumber } from '@utils/number';
import type {
EligibilityType,
OfferPlan,
OfferPlanQuote,
PacificOffer,
} from 'generated/graphql';
import { formatRoundedNumber } from '@utils/number';
import {
formatScaledPriceByCountry,
formatScaledPriceCurrency,
} from '@graphql/domain/plan/price';
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)