package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$`)
var str = `import { contextBuilder } from '@graphql/context';
import resolvers from '@graphql/resolvers';
import {
getDeviceFromHeaders,
getUserFromHeaders,
getRealIp,
} from '@utils/headers';
export * from './ChallengesAPI';
export * from './HealthDataCollectorAPI';
export * from './AlfredAPI';
import { formatRoundedNumber } from '@utils/number';
import type {
EligibilityType,
OfferPlan,
OfferPlanQuote,
PacificOffer,
} from 'generated/graphql';
import { formatRoundedNumber } from '@utils/number';
import {
formatScaledPriceByCountry,
formatScaledPriceCurrency,
} from '@graphql/domain/plan/price';
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}