use strict;
my $str = 'import { contextBuilder } from \'@graphql/context\';
import resolvers from \'@graphql/resolvers\';
import {
getDeviceFromHeaders,
getUserFromHeaders,
getRealIp,
} from \'@utils/headers\';
export * from \'./ChallengesAPI\';
export * from \'./HealthDataCollectorAPI\';
export * from \'./AlfredAPI\';
import { formatRoundedNumber } from \'@utils/number\';
import type {
EligibilityType,
OfferPlan,
OfferPlanQuote,
PacificOffer,
} from \'generated/graphql\';
import { formatRoundedNumber } from \'@utils/number\';
import {
formatScaledPriceByCountry,
formatScaledPriceCurrency,
} from \'@graphql/domain/plan/price\';
';
my $regex = qr/^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}