import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(import|export).*(\\{[^\\{\\}]*\\n\\})?.*'(?<file>.*)'.*$";
final String string = "import { contextBuilder } from '@graphql/context';\n"
+ "import resolvers from '@graphql/resolvers';\n"
+ "import {\n"
+ " getDeviceFromHeaders,\n"
+ " getUserFromHeaders,\n"
+ " getRealIp,\n"
+ "} from '@utils/headers';\n"
+ "export * from './ChallengesAPI';\n"
+ "export * from './HealthDataCollectorAPI';\n"
+ "export * from './AlfredAPI';\n"
+ "import { formatRoundedNumber } from '@utils/number';\n"
+ "import type {\n"
+ " EligibilityType,\n"
+ " OfferPlan,\n"
+ " OfferPlanQuote,\n"
+ " PacificOffer,\n"
+ "} from 'generated/graphql';\n"
+ "import { formatRoundedNumber } from '@utils/number';\n"
+ "import {\n"
+ " formatScaledPriceByCountry,\n"
+ " formatScaledPriceCurrency,\n"
+ "} from '@graphql/domain/plan/price';\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}