#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$"
Local $sString = "import { contextBuilder } from '@graphql/context';" & @CRLF & _
"import resolvers from '@graphql/resolvers';" & @CRLF & _
"import {" & @CRLF & _
" getDeviceFromHeaders," & @CRLF & _
" getUserFromHeaders," & @CRLF & _
" getRealIp," & @CRLF & _
"} from '@utils/headers';" & @CRLF & _
"export * from './ChallengesAPI';" & @CRLF & _
"export * from './HealthDataCollectorAPI';" & @CRLF & _
"export * from './AlfredAPI';" & @CRLF & _
"import { formatRoundedNumber } from '@utils/number';" & @CRLF & _
"import type {" & @CRLF & _
" EligibilityType," & @CRLF & _
" OfferPlan," & @CRLF & _
" OfferPlanQuote," & @CRLF & _
" PacificOffer," & @CRLF & _
"} from 'generated/graphql';" & @CRLF & _
"import { formatRoundedNumber } from '@utils/number';" & @CRLF & _
"import {" & @CRLF & _
" formatScaledPriceByCountry," & @CRLF & _
" formatScaledPriceCurrency," & @CRLF & _
"} from '@graphql/domain/plan/price';" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")