re = /^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$/m
str = 'import { contextBuilder } from \'@graphql/context\';
import resolvers from \'@graphql/resolvers\';
import {
getDeviceFromHeaders,
getUserFromHeaders,
getRealIp,
} from \'@utils/headers\';
export * from \'./ChallengesAPI\';
export * from \'./HealthDataCollectorAPI\';
export * from \'./AlfredAPI\';
import { formatRoundedNumber } from \'@utils/number\';
import type {
EligibilityType,
OfferPlan,
OfferPlanQuote,
PacificOffer,
} from \'generated/graphql\';
import { formatRoundedNumber } from \'@utils/number\';
import {
formatScaledPriceByCountry,
formatScaledPriceCurrency,
} from \'@graphql/domain/plan/price\';
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end