// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$").unwrap();
let string = "import { contextBuilder } from '@graphql/context';
import resolvers from '@graphql/resolvers';
import {
getDeviceFromHeaders,
getUserFromHeaders,
getRealIp,
} from '@utils/headers';
export * from './ChallengesAPI';
export * from './HealthDataCollectorAPI';
export * from './AlfredAPI';
import { formatRoundedNumber } from '@utils/number';
import type {
EligibilityType,
OfferPlan,
OfferPlanQuote,
PacificOffer,
} from 'generated/graphql';
import { formatRoundedNumber } from '@utils/number';
import {
formatScaledPriceByCountry,
formatScaledPriceCurrency,
} from '@graphql/domain/plan/price';
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}