using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(import|export).*({[^{}]*\n})?.*'(?<file>.*)'.*$";
string input = @"import { contextBuilder } from '@graphql/context';
import resolvers from '@graphql/resolvers';
import {
getDeviceFromHeaders,
getUserFromHeaders,
getRealIp,
} from '@utils/headers';
export * from './ChallengesAPI';
export * from './HealthDataCollectorAPI';
export * from './AlfredAPI';
import { formatRoundedNumber } from '@utils/number';
import type {
EligibilityType,
OfferPlan,
OfferPlanQuote,
PacificOffer,
} from 'generated/graphql';
import { formatRoundedNumber } from '@utils/number';
import {
formatScaledPriceByCountry,
formatScaledPriceCurrency,
} from '@graphql/domain/plan/price';
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}