import Foundation
let pattern = #"^(?:\+?7|8)?(?:[\s\-(_]+)?(\d{3})(?:[\s\-_)]+)?(\d{3})(?:[\s\-_]+)?(\d{2})(?:[\s\-_]+)?(\d{2})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
+78005553535
88005553535
8005553535
78005553535
+7(800)555-35-35
+7(800)5553535
+7(800)555 35 35
+7 (800) 555 35 35
+7 (800) 555-35-35
+7-(800)-555-35-35
8 (800) 555 35 35
800 555 35 35
800-555-35-35
8(800)5553535
8(800)555 35 35
8(800) 555-35-35
8-800-555-35-35
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)