package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sm)^(?:\+?7|8)?(?:[\s\-(_]+)?(\d{3})(?:[\s\-_)]+)?(\d{3})(?:[\s\-_]+)?(\d{2})(?:[\s\-_]+)?(\d{2})$`)
var str = `+78005553535
88005553535
8005553535
78005553535
+7(800)555-35-35
+7(800)5553535
+7(800)555 35 35
+7 (800) 555 35 35
+7 (800) 555-35-35
+7-(800)-555-35-35
8 (800) 555 35 35
800 555 35 35
800-555-35-35
8(800)5553535
8(800)555 35 35
8(800) 555-35-35
8-800-555-35-35`
var substitution = "$1$2$3$4"
fmt.Println(re.ReplaceAllString(str, substitution))
}