using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\+?7|8)?(?:[\s\-(_]+)?(\d{3})(?:[\s\-_)]+)?(\d{3})(?:[\s\-_]+)?(\d{2})(?:[\s\-_]+)?(\d{2})$";
string substitution = @"$1$2$3$4";
string input = @"+78005553535
88005553535
8005553535
78005553535
+7(800)555-35-35
+7(800)5553535
+7(800)555 35 35
+7 (800) 555 35 35
+7 (800) 555-35-35
+7-(800)-555-35-35
8 (800) 555 35 35
800 555 35 35
800-555-35-35
8(800)5553535
8(800)555 35 35
8(800) 555-35-35
8-800-555-35-35";
RegexOptions options = RegexOptions.Singleline | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}