# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?:\+?7|8)?(?:[\s\-(_]+)?(\d{3})(?:[\s\-_)]+)?(\d{3})(?:[\s\-_]+)?(\d{2})(?:[\s\-_]+)?(\d{2})$/$1$2$3$4/smg;t' <<< "+78005553535
88005553535
8005553535
78005553535
+7(800)555-35-35
+7(800)5553535
+7(800)555 35 35
+7 (800) 555 35 35
+7 (800) 555-35-35
+7-(800)-555-35-35
8 (800) 555 35 35
800 555 35 35
800-555-35-35
8(800)5553535
8(800)555 35 35
8(800) 555-35-35
8-800-555-35-35"