#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sm)^(?:\+?7|8)?(?:[\s\-(_]+)?(\d{3})(?:[\s\-_)]+)?(\d{3})(?:[\s\-_]+)?(\d{2})(?:[\s\-_]+)?(\d{2})$"
Local $sString = "+78005553535" & @CRLF & _
"88005553535" & @CRLF & _
"8005553535" & @CRLF & _
"78005553535" & @CRLF & _
"+7(800)555-35-35" & @CRLF & _
"+7(800)5553535" & @CRLF & _
"+7(800)555 35 35" & @CRLF & _
"+7 (800) 555 35 35" & @CRLF & _
"+7 (800) 555-35-35" & @CRLF & _
"+7-(800)-555-35-35" & @CRLF & _
"8 (800) 555 35 35" & @CRLF & _
"800 555 35 35" & @CRLF & _
"800-555-35-35" & @CRLF & _
"8(800)5553535" & @CRLF & _
"8(800)555 35 35" & @CRLF & _
"8(800) 555-35-35" & @CRLF & _
"8-800-555-35-35"
Local $sSubst = "$1$2$3$4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)