import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+?7|8)?(?:[\\s\\-(_]+)?(\\d{3})(?:[\\s\\-_)]+)?(\\d{3})(?:[\\s\\-_]+)?(\\d{2})(?:[\\s\\-_]+)?(\\d{2})$";
final String string = "+78005553535\n"
+ "88005553535\n"
+ "8005553535\n"
+ "78005553535\n"
+ "+7(800)555-35-35\n"
+ "+7(800)5553535\n"
+ "+7(800)555 35 35\n"
+ "+7 (800) 555 35 35\n"
+ "+7 (800) 555-35-35\n"
+ "+7-(800)-555-35-35\n"
+ "8 (800) 555 35 35\n"
+ "800 555 35 35\n"
+ "800-555-35-35\n"
+ "8(800)5553535\n"
+ "8(800)555 35 35\n"
+ "8(800) 555-35-35\n"
+ "8-800-555-35-35";
final String subst = "$1$2$3$4";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}