# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\+?7|8)?(?:[\s\-(_]+)?(\d{3})(?:[\s\-_)]+)?(\d{3})(?:[\s\-_]+)?(\d{2})(?:[\s\-_]+)?(\d{2})$"
test_str = ("+78005553535\n"
"88005553535\n"
"8005553535\n"
"78005553535\n"
"+7(800)555-35-35\n"
"+7(800)5553535\n"
"+7(800)555 35 35\n"
"+7 (800) 555 35 35\n"
"+7 (800) 555-35-35\n"
"+7-(800)-555-35-35\n"
"8 (800) 555 35 35\n"
"800 555 35 35\n"
"800-555-35-35\n"
"8(800)5553535\n"
"8(800)555 35 35\n"
"8(800) 555-35-35\n"
"8-800-555-35-35")
subst = "$1$2$3$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.