const regex = /^(?:\+?7|8)?(?:[\s\-(_]+)?(\d{3})(?:[\s\-_)]+)?(\d{3})(?:[\s\-_]+)?(\d{2})(?:[\s\-_]+)?(\d{2})$/smg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\+?7|8)?(?:[\\s\\-(_]+)?(\\d{3})(?:[\\s\\-_)]+)?(\\d{3})(?:[\\s\\-_]+)?(\\d{2})(?:[\\s\\-_]+)?(\\d{2})$', 'smg')
const str = `+78005553535
88005553535
8005553535
78005553535
+7(800)555-35-35
+7(800)5553535
+7(800)555 35 35
+7 (800) 555 35 35
+7 (800) 555-35-35
+7-(800)-555-35-35
8 (800) 555 35 35
800 555 35 35
800-555-35-35
8(800)5553535
8(800)555 35 35
8(800) 555-35-35
8-800-555-35-35`;
const subst = `$1$2$3$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);