import Foundation
let pattern = #"\d{4}\.\d{2}\.\d{2}-r\d{2,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[
{
"changeableAttributes": {
"deleteEnabled": true,
"listEnabled": true,
"readEnabled": true,
"writeEnabled": true
},
"createdTime": "2020-06-03T16:21:24.0805118Z",
"digest": "sha256:a31ccfcdfabfcebd5033efa36ebc017fc4264db2c166894283b5e5d12a42636f",
"lastUpdateTime": "2020-06-03T16:21:24.0805118Z",
"name": "2020.06.03-r01",
"signed": false
}
]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)