using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{4}\.\d{2}\.\d{2}-r\d{2,}";
string input = @"[
{
""changeableAttributes"": {
""deleteEnabled"": true,
""listEnabled"": true,
""readEnabled"": true,
""writeEnabled"": true
},
""createdTime"": ""2020-06-03T16:21:24.0805118Z"",
""digest"": ""sha256:a31ccfcdfabfcebd5033efa36ebc017fc4264db2c166894283b5e5d12a42636f"",
""lastUpdateTime"": ""2020-06-03T16:21:24.0805118Z"",
""name"": ""2020.06.03-r01"",
""signed"": false
}
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}