// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d{4}\.\d{2}\.\d{2}-r\d{2,}").unwrap();
let string = "[
{
\"changeableAttributes\": {
\"deleteEnabled\": true,
\"listEnabled\": true,
\"readEnabled\": true,
\"writeEnabled\": true
},
\"createdTime\": \"2020-06-03T16:21:24.0805118Z\",
\"digest\": \"sha256:a31ccfcdfabfcebd5033efa36ebc017fc4264db2c166894283b5e5d12a42636f\",
\"lastUpdateTime\": \"2020-06-03T16:21:24.0805118Z\",
\"name\": \"2020.06.03-r01\",
\"signed\": false
}
]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}