#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d{4}\.\d{2}\.\d{2}-r\d{2,}"
Local $sString = "[" & @CRLF & _
" {" & @CRLF & _
" "changeableAttributes": {" & @CRLF & _
" "deleteEnabled": true," & @CRLF & _
" "listEnabled": true," & @CRLF & _
" "readEnabled": true," & @CRLF & _
" "writeEnabled": true" & @CRLF & _
" }," & @CRLF & _
" "createdTime": "2020-06-03T16:21:24.0805118Z"," & @CRLF & _
" "digest": "sha256:a31ccfcdfabfcebd5033efa36ebc017fc4264db2c166894283b5e5d12a42636f"," & @CRLF & _
" "lastUpdateTime": "2020-06-03T16:21:24.0805118Z"," & @CRLF & _
" "name": "2020.06.03-r01"," & @CRLF & _
" "signed": false" & @CRLF & _
" }" & @CRLF & _
"]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")