const regex = /\d{4}\.\d{2}\.\d{2}-r\d{2,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d{4}\\.\\d{2}\\.\\d{2}-r\\d{2,}', 'gm')
const str = `[
{
"changeableAttributes": {
"deleteEnabled": true,
"listEnabled": true,
"readEnabled": true,
"writeEnabled": true
},
"createdTime": "2020-06-03T16:21:24.0805118Z",
"digest": "sha256:a31ccfcdfabfcebd5033efa36ebc017fc4264db2c166894283b5e5d12a42636f",
"lastUpdateTime": "2020-06-03T16:21:24.0805118Z",
"name": "2020.06.03-r01",
"signed": false
}
]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}