import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{4}\\.\\d{2}\\.\\d{2}-r\\d{2,}";
final String string = "[\n"
+ " {\n"
+ " \"changeableAttributes\": {\n"
+ " \"deleteEnabled\": true,\n"
+ " \"listEnabled\": true,\n"
+ " \"readEnabled\": true,\n"
+ " \"writeEnabled\": true\n"
+ " },\n"
+ " \"createdTime\": \"2020-06-03T16:21:24.0805118Z\",\n"
+ " \"digest\": \"sha256:a31ccfcdfabfcebd5033efa36ebc017fc4264db2c166894283b5e5d12a42636f\",\n"
+ " \"lastUpdateTime\": \"2020-06-03T16:21:24.0805118Z\",\n"
+ " \"name\": \"2020.06.03-r01\",\n"
+ " \"signed\": false\n"
+ " }\n"
+ "]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}