# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d{4}\.\d{2}\.\d{2}-r\d{2,}"
test_str = ("[\n"
" {\n"
" \"changeableAttributes\": {\n"
" \"deleteEnabled\": true,\n"
" \"listEnabled\": true,\n"
" \"readEnabled\": true,\n"
" \"writeEnabled\": true\n"
" },\n"
" \"createdTime\": \"2020-06-03T16:21:24.0805118Z\",\n"
" \"digest\": \"sha256:a31ccfcdfabfcebd5033efa36ebc017fc4264db2c166894283b5e5d12a42636f\",\n"
" \"lastUpdateTime\": \"2020-06-03T16:21:24.0805118Z\",\n"
" \"name\": \"2020.06.03-r01\",\n"
" \"signed\": false\n"
" }\n"
"]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.