re = /\d{4}\.\d{2}\.\d{2}-r\d{2,}/m
str = '[
{
"changeableAttributes": {
"deleteEnabled": true,
"listEnabled": true,
"readEnabled": true,
"writeEnabled": true
},
"createdTime": "2020-06-03T16:21:24.0805118Z",
"digest": "sha256:a31ccfcdfabfcebd5033efa36ebc017fc4264db2c166894283b5e5d12a42636f",
"lastUpdateTime": "2020-06-03T16:21:24.0805118Z",
"name": "2020.06.03-r01",
"signed": false
}
]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end