import Foundation
let pattern = #""(.+?)": "[\^]*(.+?)",\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"es6-shim": "^0.35.0",
"lodash": "^4.13.1",
"ng2-bootstrap": "^1.0.16",
"reflect-metadata": "0.1.3",
"rxjs": "5.0.0-beta.6",
"systemjs": "0.19.26",
"zone.js": "^0.6.12"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1@$2 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)