// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""(.+?)": "[\^]*(.+?)",\n"#).unwrap();
let string = "\"es6-shim\": \"^0.35.0\",
\"lodash\": \"^4.13.1\",
\"ng2-bootstrap\": \"^1.0.16\",
\"reflect-metadata\": \"0.1.3\",
\"rxjs\": \"5.0.0-beta.6\",
\"systemjs\": \"0.19.26\",
\"zone.js\": \"^0.6.12\"";
let substitution = "$1@$2 ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}