import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(.+?)\": \"[\\^]*(.+?)\",\\n";
final String string = "\"es6-shim\": \"^0.35.0\",\n"
+ "\"lodash\": \"^4.13.1\",\n"
+ "\"ng2-bootstrap\": \"^1.0.16\",\n"
+ "\"reflect-metadata\": \"0.1.3\",\n"
+ "\"rxjs\": \"5.0.0-beta.6\",\n"
+ "\"systemjs\": \"0.19.26\",\n"
+ "\"zone.js\": \"^0.6.12\"";
final String subst = "$1@$2 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}