using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(.+?)"": ""[\^]*(.+?)"",\n";
string substitution = @"$1@$2 ";
string input = @"""es6-shim"": ""^0.35.0"",
""lodash"": ""^4.13.1"",
""ng2-bootstrap"": ""^1.0.16"",
""reflect-metadata"": ""0.1.3"",
""rxjs"": ""5.0.0-beta.6"",
""systemjs"": ""0.19.26"",
""zone.js"": ""^0.6.12""";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}