const regex = /"(.+?)": "[\^]*(.+?)",\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"(.+?)": "[\\^]*(.+?)",\\n', 'g')
const str = `"es6-shim": "^0.35.0",
"lodash": "^4.13.1",
"ng2-bootstrap": "^1.0.16",
"reflect-metadata": "0.1.3",
"rxjs": "5.0.0-beta.6",
"systemjs": "0.19.26",
"zone.js": "^0.6.12"`;
const subst = `$1@$2 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);