# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(.+?)\": \"[\^]*(.+?)\",\n"
test_str = ("\"es6-shim\": \"^0.35.0\",\n"
"\"lodash\": \"^4.13.1\",\n"
"\"ng2-bootstrap\": \"^1.0.16\",\n"
"\"reflect-metadata\": \"0.1.3\",\n"
"\"rxjs\": \"5.0.0-beta.6\",\n"
"\"systemjs\": \"0.19.26\",\n"
"\"zone.js\": \"^0.6.12\"")
subst = "$1@$2 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.