// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\d]{0,4}[\;][\d][\;][\d]{0,10}[\;][A-Z][\;][\s\S][\;][\s\S][\;]").unwrap();
let string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>\\r\\n<string xmlns=\"xxxxxxxxx\">4566;1;1675879451;A;;;;;</string>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}