#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[\d]{0,4}[\;][\d][\;][\d]{0,10}[\;][A-Z][\;][\s\S][\;][\s\S][\;]"
Local $sString = "<?xml version="1.0" encoding="utf-8"?>\r\n<string xmlns="xxxxxxxxx">4566;1;1675879451;A;;;;;</string>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")