re = /[\d]{0,4}[\;][\d][\;][\d]{0,10}[\;][A-Z][\;][\s\S][\;][\s\S][\;]/m
str = '<?xml version="1.0" encoding="utf-8"?>\\r\\n<string xmlns="xxxxxxxxx">4566;1;1675879451;A;;;;;</string>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end