const regex = /[\d]{0,4}[\;][\d][\;][\d]{0,10}[\;][A-Z][\;][\s\S][\;][\s\S][\;]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d]{0,4}[\\;][\\d][\\;][\\d]{0,10}[\\;][A-Z][\\;][\\s\\S][\\;][\\s\\S][\\;]', 'gm')
const str = `<?xml version="1.0" encoding="utf-8"?>\\r\\n<string xmlns="xxxxxxxxx">4566;1;1675879451;A;;;;;</string>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}