using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\d]{0,4}[\;][\d][\;][\d]{0,10}[\;][A-Z][\;][\s\S][\;][\s\S][\;]";
string input = @"<?xml version=""1.0"" encoding=""utf-8""?>\r\n<string xmlns=""xxxxxxxxx"">4566;1;1675879451;A;;;;;</string>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}