import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d]{0,4}[\\;][\\d][\\;][\\d]{0,10}[\\;][A-Z][\\;][\\s\\S][\\;][\\s\\S][\\;]";
final String string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>\\r\\n<string xmlns=\"xxxxxxxxx\">4566;1;1675879451;A;;;;;</string>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}