package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\d]{0,4}[\;][\d][\;][\d]{0,10}[\;][A-Z][\;][\s\S][\;][\s\S][\;]`)
var str = `<?xml version="1.0" encoding="utf-8"?>\r\n<string xmlns="xxxxxxxxx">4566;1;1675879451;A;;;;;</string>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}