import Foundation
let pattern = #"\bCURRENT\s*DATE\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
* RNN_FECULACT = CURRENT DATE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"SYSDATE"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)