$re = '/\bCURRENT\s*DATE\b/m';
$str = '* RNN_FECULACT = CURRENT DATE
';
$subst = "SYSDATE";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;