use strict;
my $str = '* RNN_FECULACT = CURRENT DATE
';
my $regex = qr/\bCURRENT\s*DATE\b/mp;
my $subst = 'SYSDATE';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";