using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bCURRENT\s*DATE\b";
string substitution = @"SYSDATE";
string input = @"* RNN_FECULACT = CURRENT DATE
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}