re = /\bCURRENT\s*DATE\b/m
str = '* RNN_FECULACT = CURRENT DATE
'
subst = 'SYSDATE'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result