// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bCURRENT\s*DATE\b").unwrap();
let string = "* RNN_FECULACT = CURRENT DATE
";
let substitution = "SYSDATE";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}