const regex = /\bCURRENT\s*DATE\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bCURRENT\\s*DATE\\b', 'gm')
const str = `* RNN_FECULACT = CURRENT DATE
`;
const subst = `SYSDATE`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);